Degraded voice performance due to SBC latency
Monitoring·Partial outage

We've been informed by our Vendor Engineering team and their ISP Infrastructure team that the issue has been fixed. Should any performance issues be detected, we will provide a prompt update and prioritize the investigation accordingly.

Thu, Jan 8, 2026, 02:08 PM
(8 hours ago)
·
Affected components
Voice Services
Updates

Monitoring

We've been informed by our Vendor Engineering team and their ISP Infrastructure team that the issue has been fixed. Should any performance issues be detected, we will provide a prompt update and prioritize the investigation accordingly.

Thu, Jan 8, 2026, 02:08 PM

Investigating

Unfortunately this issue is still ongoing and has been escalated again with our SBC vendor's ISP. Our Voice Engineering team have performed changes to mitigate the issue with positive results in our statistics until we get a permanent fix. Further updates will be provided as soon as they are available.

Wed, Jan 7, 2026, 01:50 PM(1 day earlier)

Investigating

The issue is still ongoing and it's being investigated by our Voice Engineering team along with the Vendor's Infrastructure team. As soon as further updates are available, will let you know.

Wed, Jan 7, 2026, 12:12 PM(1 hour earlier)

Investigating

Unfortunately the increased latency issue on the SBC, leading to degraded voice performance, is still ongoing. Impacts may include delayed call setup or reduced call quality. The issue is under investigation and updates will follow.

Wed, Jan 7, 2026, 11:02 AM(1 hour earlier)

Monitoring

Please note that we can see significant improvement of the stability for both incoming and outgoing calls. This incident is still in the monitoring phase and will keep you posted throughout the day.

Wed, Jan 7, 2026, 09:36 AM(1 hour earlier)

Monitoring

We have been informed by our vendor that the issue has now been resolved. We will continue to monitor the situation closely.

We apologise for the inconvenience caused and thank you for your continued patience.

A final update will be provided in the morning, followed by a full RCA once available.

Tue, Jan 6, 2026, 07:20 PM(14 hours earlier)

Monitoring

Mitigation measures have been applied for {service_or_component}.

Service performance is recovering and we are monitoring {metric_or_indicator} closely.

We will provide a further update once stability is confirmed.

Tue, Jan 6, 2026, 07:19 PM

Monitoring

We have been informed by our vendor that the issue has now been resolved. We will continue to monitor the situation closely. We apologise for the inconvenience caused and thank you for your continued patience. A final update will be provided in the morning, followed by a full RCA once available.

Tue, Jan 6, 2026, 07:06 PM(12 minutes earlier)

Monitoring

Our vendor continues to investigate the root cause, we will provide further updates as they become available.

Tue, Jan 6, 2026, 04:07 PM(2 hours earlier)

Monitoring

Significant improvement in quality has been seen, however intermittent calls might still experience voice quality issues caused by packet loss. Incident bridge with our vendor has been ongoing as they work to fully restore service

Tue, Jan 6, 2026, 03:15 PM(52 minutes earlier)

Identified

The situation has improved throughout the afternoon, with a reduction in failed/problematic calls due to packet loss/delays, but the service is not yet fully restored. Our vendor is currently working with their ISPs toward a final resolution.

There is no firm ETR at this time. We will provide further updates as they become available.

Tue, Jan 6, 2026, 02:05 PM(1 hour earlier)

Investigating

We have detected increased latency on the SBC, leading to degraded voice performance.
Impacts may include delayed call setup or reduced call quality on some routes.
The issue is under investigation and updates will follow.

Tue, Jan 6, 2026, 01:53 PM(12 minutes earlier)
Powered by

This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.