The cause of this incident has been determined to have been a DDoS on the main ISP.
Mitigation measures have been implemented and improved, with traffic returning to normal values
We will continue monitoring traffic before returning to normal operations.
Monitoring
The cause of this incident has been determined to have been a DDoS on the main ISP.
Mitigation measures have been implemented and improved, with traffic returning to normal values
We will continue monitoring traffic before returning to normal operations.
Identified
This incident is still ongoing and our SBC Vendor is working closely with their ISP in order to implement permanent fixes to avoid further recurrences.
As soon as further updates become available, we will let you know.
Investigating
Our SBC vendor continues to work with the upstream ISP as part of the ongoing investigation into the connectivity issues affecting the platform.
Voice services remain in a degraded state, and customers may continue to experience call quality issues and intermittent connectivity.
There is no material change to service status at this time. Investigation and mitigation activities remain ongoing, and we will provide a further update once more information becomes available.
We apologise for the continued impact and thank you for your patience.
Investigating
Our SBC vendor team are currently troubleshooting with the upstream ISP to address ongoing connectivity issues impacting the platform.
Voice services remain in a degraded state, and customers may experience inconsistent service behaviour.
Investigation and mitigation activities remain ongoing. Further updates will be provided as more information becomes available.
We apologise for the continued disruption, and appreciate your patience.
Investigating
Our SBC vendor continues to work with their ISP on mitigating actions to restore full service stability
In the meantime, clients may experience degraded voice call quality, and intermittent connectivity drops.
We apologise for the inconvenience caused.
Investigating
Unfortunately the loss of connectivity issue on the SBC, leading to degraded voice performance, is still ongoing and some of the calls, both incoming and outgoing, are affected.
We apologies for the inconvenience caused and will keep you posted.
Investigating
Unfortunately this issue is still ongoing and our SBC Vendor is working closely with their ISP to fix the intermittent loss of connectivity.
As soon as further updates are available, will let you know.
Investigating
The issue remains ongoing and is being actively addressed by our SBC vendor in coordination with their ISP.
Mitigation measures have been implemented by our Voice Engineering team that have resulted in positive improvements in voice performance.
Investigating
This issue has been escalated by our Vendor SBC with their ISP Provider due to intermittent loss of connectivity.
Unfortunately there is no firm ETR at this time. We will provide further updates as they become available.
Investigating
We are currently experiencing connectivity issues with our SBC and some of the incoming and outgoing calls are affected.
Our voice engineering team is investigating this issue and we will keep you updated throughout this process.
This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.