MNP lookups towards a UK MVNO’s native numbers receive intermittent timeouts
Monitoring·Degraded performance

A temporary fix has been put in place on 04/02 while we work with the MVNO for full service restoration.

We’re monitoring results from this fix to ensure service stability.

We apologise for the service interruption that has been encountered.

Thu, Feb 5, 2026, 07:34 AM
(2 weeks ago)
·
Affected components
Mobile Number Portability Query APIs
Updates

Monitoring

A temporary fix has been put in place on 04/02 while we work with the MVNO for full service restoration.

We’re monitoring results from this fix to ensure service stability.

We apologise for the service interruption that has been encountered.

Thu, Feb 5, 2026, 07:34 AM

Identified

The MVNO’s NOC and operations team continue to investigate these timeouts on their native subscriber base.

We’ll provide further updates as we receive them.

Sat, Jan 31, 2026, 11:24 AM(4 days earlier)

Identified

MNP lookups towards one of the UK MVNO’s native numbers are seeing intermittent timeouts. This is being investigated with their infrastructure team

Thu, Jan 29, 2026, 02:37 PM(1 day earlier)
Powered by

This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.