This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
Please be informed that the traffic has been restored.
If you continue to experience issues, please contact noc@stour.io
Identified
We are currently observing an issue affecting SMS towards Lycamobile UK.
Customers may experience delayed SMS MT and DLRs during this disturbance.
The issue is outside of our network, we shall continue to monitor the situation and advise of any updates as we receive them.
Investigating
We are currently observing an issue affecting SMS towards Lycamobile UK.
Customers may experience delayed SMS MT and DLRs during this disturbance.
The issue is outside of our network, we shall continue to monitor the situation and advise of any updates as we receive them.