This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
Please be informed that the delayed SMS delivery issue has been fixed and the traffic is now fully restored.
Identified
We are currently observing an issue affecting international P2P SMS delivery.
Customers may experience delayed SMS delivery during this disturbance.
One of our P2P Hub providers has an open incident on their network, we will monitor and advise when service is fully restored their side.