This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
The issue affecting MNP Lookup queries has been resolved at 11:55 AM UTC, 13th March 2026.
Service performance has returned to normal.
If you continue to experience issues, please contact support@stour.io
Resolved
The issue affecting MNP Lookup queries has been resolved at 11:55 AM UTC, 13th March 2026.
Service performance has returned to normal.
If you continue to experience issues, please contact support@stour.io
Monitoring
Service performance is recovering and we are monitoring MNP Lookup queries closely.
We will provide a further update once stability is confirmed.
Investigating
We are currently investigating an issue affecting MNP Lookups towards EE UK.
Customers may experience queries that fail with a timeout towards EE subscribers, or those with a number ported out of EE.
Our team is actively investigating and we will provide further updates as more information becomes available.