This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
Lycamobile engineers have solved the internal issues and connectivity has been restored.
Investigating
Lycamobile are experiencing an intermittent outage.
Customers may experience delayed SMS delivery to Lycamobile subscribers.
Their technical team is actively working to restore the services