This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
Service stability has resumed on Lycamobile UK.
We will continue monitoring while we wait an official communication from the operator.
Monitoring
We are currently monitoring an issue affecting Lycamobile UK, pending an update from the operator that their service has been fully restored.
Investigating
Lycamobile are currently investigating an issue affecting their network in the UK.
Customers may experience delayed/failed SMS and number queries towards Lycamobile UK.
Our team will provide further updates as more information becomes available from Lycamobile.