This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
The issue affecting SMS Delivery delays to EE subscribers have been resolved by EE Engineers.
Service performance has returned to normal.
If you continue to experience issues, please contact support@stour.io
Investigating
We are currently investigating an issue affecting SMS delivery to EE Network.
Customers may experience intermittent delays for messages sent to EE subscribers (native and ported to EE).
Our team is working closely with EE Support in order to resolve this issue.