This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
The issue affecting Lycamobile has been resolved, with delivery rates recovering since 1am BST.
Service performance has returned to normal, so we are resolving this incident pending an update from the impacted operator.
If you continue to experience issues, please contact support@stour.io
Resolved
The issue affecting Lycamobile has been resolved, with delivery rates recovering since 1am BST.
Service performance has returned to normal, so we are resolving this incident pending an update from the impacted operator.
If you continue to experience issues, please contact support@stour.io
Monitoring
Based on our monitoring, messages to LycaMobile UK have started to be delivered and the issue might have been resolved.
We are constantly chasing their Messaging & Support teams for an official update and will keep monitor closely this issue.
Further updates will be published as soon as they are available.
Identified
The issues impacting Lycamobile UK continue.
Our engineers will monitor for improvements, or updates from Lycamobile.
As this is an event outside of our network, we’ll endeavour to share the next update in eight hours.
Identified
We continue to observe an issue affecting Lycamobile UK.
Customers may experience delayed and/or failed SMS, and MNP timeouts.
Our team are pursuing Lycamobile for an update that we can share.
Investigating
We are currently aware of an external issue affecting Lycamobile UK.
Customers may experience delayed SMS, and MNP failures.
Our team are actively monitoring and will provide further updates as more information becomes available.