This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
The issue affecting Lycamobile has been resolved.
Service performance has returned to normal, with SMS delivery rate above 90% for the past hour, so we are closing this incident.
If you continue to experience issues, please contact support@stour.io
Resolved
The issue affecting Lycamobile has been resolved.
Service performance has returned to normal, with SMS delivery rate above 90% for the past hour, so we are closing this incident.
If you continue to experience issues, please contact support@stour.io
Monitoring
We are observing a recovery in message delivery towards Lycamobile UK over the past hour.
Whilst performance is recovering, we will continue monitoring Lycamobile UK.
A further update will be provided once stability is confirmed.
Investigating
We are still observing an issue affecting Lycamobile UK.
Customers may continue to experience delayed/failed SMS, and failed MNP queries.
Engineers at Lycamobile are working to restore service. We will share further information as it becomes available.
Investigating
We are still observing an issue affecting Lycamobile UK.
Customers may continue to experience delayed/failed SMS, and failed MNP queries.
Our team are requesting further updates from Lycamobile, we will share more information as it becomes available.
Investigating
We are currently investigating a recurrence of issues affecting Lycamobile UK.
Customers may experience delayed/failed SMS, and MNP timeouts.
Our team are actively investigating, we will provide further updates as more information becomes available. We have engaged Lycamobile for further information.