This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
The issue affecting A2P SMS Delivery Receipts has been resolved.
Service performance has returned to normal, and remained stable for the past hour of monitoring.
Our engineers will work on the recovery of error state Delivery Receipts from the impacted period, this will commence tomorrow morning.
If you continue to experience issues, please contact support@stour.io
Resolved
The issue affecting A2P SMS Delivery Receipts has been resolved.
Service performance has returned to normal, and remained stable for the past hour of monitoring.
Our engineers will work on the recovery of error state Delivery Receipts from the impacted period, this will commence tomorrow morning.
If you continue to experience issues, please contact support@stour.io
Monitoring
Our engineers have identified and fixed the issue affecting A2P SMS Delivery Receipts.
Service performance has recovered, Delivery Receipts for new message submissions are being processed as normal, and monitored by our team.
We will provide a further update this evening regarding the delivery receipts that were queued during this incident.
Identified
The cause of an issue affecting A2P SMS Delivery Receipts has been identified by our engineers, and is being worked on.
The issue may result in customers experiencing delayed processing of A2P SMS Delivery Receipts.
We will share further updates shortly.
Investigating
We are currently investigating an issue affecting A2P SMS delivery receipts.
Customers may experience a delay in delivery receipts being processed for some A2P traffic. We have confirmed with suppliers that MT SMS delivery is not currently impacted.
Our team are actively investigating and we will provide further updates as more information becomes available.