This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
The issue affecting Lycamobile UK has been resolved.
Service performance has returned to normal, and the operator has confirmed actions taken their side.
If you continue to experience issues, please contact support@stour.io
Monitoring
We are observing a recovery in message delivery towards Lycamobile UK over the past hours.
Whilst performance is recovering, we will continue monitoring the traffic.
A further update will be provided once stability is confirmed.
Investigating
We are currently investigating an issue affecting Lycamobile UK.
Customers may experience SMS delivery delays and/or failures, MNP query delays and/or failures.
This is an external network disturbance, we will provide further updates as more information becomes available.