This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
Resolved
The issue affecting Lycamobile UK has been resolved.
Service performance has returned to normal.
If you continue to experience issues, please contact support@stour.io
Monitoring
Recovery in performance has been observed for Lycamobile UK.
We are monitoring performance stability to ensure ongoing recovery.
We will provide a further update once stability is confirmed.
Investigating
We are currently investigating an issue affecting Lycamobile UK.
Customers may experience failed or delayed SMS, DLR and MNP queries.
Our team is actively investigating and we will provide further updates as more information becomes available.