This status page reflects incidents and maintenance events recorded since it was introduced in January 2026.
We can see that the traffic performance towards Lycamobile is stable and the issue seems to have been resolved.
If you continue to experience issues, please contact support@stour.io
Resolved
We can see that the traffic performance towards Lycamobile is stable and the issue seems to have been resolved.
If you continue to experience issues, please contact support@stour.io
Monitoring
The message delivery and DLRs performance towards Lycamobile has improved over the night, based on our statistics.
We are actively monitoring the issue and further updates will be posted as soon as they are available.
Identified
Following our investigation, the issue is within Lyca's network and this has been escalated with their teams.
The delivery rate has improved in the past hour, however, we're waiting for updates from their end.
Further updates will be published here as soon as they are available.
Investigating
We are currently investigating an issue affecting Lycamobile UK.
Customers may experience delayed message delivery and/or DLRs. MNP perfomance may also be impacted.
Our team are actively investigating and we will provide further updates as more information becomes available from Lycamobile.